GimbalGuru.com
Uncategorized

Oculus Rift and Touch may work better in USB 2.0 for some PCs

Oculus has been adamant that the Oculus Rift requires three USB 3.0 ports and one USB 2.0 port.  However, it appears not only that the Rift and Touch can work with just USB 2.0, but that it may even perform better for some PCs!  (In my case, it solved missing sound from the headphones and random disconnections.)


Oculus has always maintained that the Rift and Touch require three USB 3.0 ports and one USB 2.0 port:
– one USB 3.0 for the headset
– one USB 3.0 for the sensor that is included with the Rift
– one USB 3.0 for the additional sensor included with the Touch
– one USB 2.0 for the wireless adapter for the Xbox controller.

For users who don’t have a USB 3.0 port, Oculus recommends getting a PCI-E card with a Fresco Logic FL1100EX chipset.  I got one called Inateck, which was recommended by Oculus.

THE PROBLEM
However, ever since I got the Oculus Rift, I have had a couple of issues:  First, there would often be no sound from the headphones, even if I specified that the audio output would be from the headphones.  When there is no sound, I found that I needed to unplug and replug the HDMI or the USB.  After perhaps five to ten attempts, I would finally get sound.  It was quite annoying, but I didn’t know what was causing it, and I wondered if it might be a defective cable (I bought a used Rift, so who knows what the previous owner might have done).

Second, occasionally, the headset would just suddenly stop tracking and then I would get a notification that the headset was disconnected.  I would then have to close Oculus Home, reconnect the headset, and restart Oculus Home, and the issue would be fixed (except that I would have lost any unsaved progress).  After I got the Oculus Touch last night, I noticed that this would happen more often.  I dreaded the possibility of this happening in the middle of an online PvP battle.

A third issue is that my headset would always show up in the settings as being connected via USB 2.0, while the sensors were recognized as USB 3.0.  It didn’t have any noticeable effect on performance, and on the /r/Oculus subreddit, there were other people who experienced this and just brushed it off.

THE SOLUTION
Since the disconnections seemed to happen more often with Oculus Touch, I thought that perhaps it has something to do with the USB controller bandwidth.  When using the Touch, you need a second sensor, connected via USB 3.0, which will require using more of the bandwidth.

Meanwhile Oculus said that if you attach a third sensor, they recommend using USB 2.0 because the bandwidth could be exceeded.

This gave me the idea of switching one of my sensors to USB 2.0 (one sensor connected via USB 3.0, the other one connected via USB 2.0).  I tried it and it seemed to work fine.  I took it one step further and tried connecting both cameras via USB 2.0.  Again, it continued to work.  I didn’t notice any deterioration in tracking.  I also noticed that when both sensors were connected via USB 2.0, the headset is recognized as USB 3.0 — the first time that ever happened for me!

I tested the performance but unfortunately I was still getting random disconnections.  I wondered what would happen if I connected the headset via USB 2.0.

THE RESULT
Connecting the headset via USB 2.0 not only worked, but it worked better.  First of all, it continued to track as well as when it’s connected via USB 3.0.  In fact, my sensors are each connected with a [passive] USB extension cable, but the tracking still works, just as well as when I’m connected via USB 3.0.  Second, connecting via USB 2.0 solved the sound problem.  When connected via USB 2.0, I would always get sound in the headphones.  Third, connecting the headset via USB 2.0 also appears to have solved the random disconnections.  Ever since I connected the headset via USB 2.0, I have not experienced the random disconnections.

So if you are experiencing any of the issues I described, try connecting via USB 2.0 to see if it solves those problems.  Also, if you are considering getting an Oculus Rift but don’t have enough USB 3.0 ports on your PC, I would not worry about it.

About the author

Mic Ty

6 Comments

Click here to post a comment

  • I too have moved to USB 2.0 on my ASUS MOBO as i was getting no sound in games, and had to go into the sound setting before it would start. My sensor was has never worked on USB 3. I can't see any difference on USB 2.0 and all my sound problems have gone. That's how i found this page. Glad i'm not the only one.

    • Hi Sebastien. I used usb 2.0 for the headset and two sensors. For my third sensor i had to use a usb 3.0 port just for the third sensor (all others still usb 2.0) or else it would say poor tracking.

      Best regards,
      Mic

    • Congratulations Tyler! I'm sure you will love it! And yes don't worry, the Rift can run on USB 2.0 (headset and 2 sensors). Only if you add a third sensor might you need one USB 3.0 (in addition to three USB 2.0).

      Best regards,
      Mic